You are currently viewing a snapshot of taken on April 21, 2008. Most of this content is highly out of date (some pages haven't been updated since the project began in 1998) and exists for historical purposes only. If there are any pages on this archive site that you think should be added back to, please file a bug.

You are here: Known Vulnerabilities in Mozilla Products (Firefox > MFSA 2007-19

Mozilla Foundation Security Advisory 2007-19

Title: XSS using addEventListener and setTimeout
Impact: High
Announced: July 17, 2007
Products: Firefox

Fixed in: Firefox
  SeaMonkey 1.1.3


Mozilla contributor moz_bug_r_a4 demonstrated that the methods addEventListener and setTimeout could be used to inject script into another site in violation of the browser's same-origin policy. This could be used to access or modify private or valuable information from that other site.